Issues with downstream KYC provider causing intermittent issues

Incident Report for HFD

Resolved

Issue has been resolved by downstream provider. Closing incident
Posted Apr 03, 2026 - 09:19 PDT

Monitoring

Issue seems to be resolved by downstream provider. Monitoring
Posted Apr 03, 2026 - 09:17 PDT

Update

Verified this is affecting only ITIN endpoint calls. We are re-enabling the pipelines, and are continuing to work with the 3rd party vendor
Posted Apr 03, 2026 - 08:07 PDT

Update

We are working with our downstream vendor and at this time are bypassing their service to allow all traffic through.
Posted Apr 03, 2026 - 07:52 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 03, 2026 - 07:51 PDT

Investigating

We are currently investigating this issue.
Posted Apr 03, 2026 - 07:23 PDT
This incident affected: Easy Apply.